Isotropix Forums

cnode render hangs at 99% completion

You think you may have found a bug? Please post it here.

cnode render hangs at 99% completion

Unread postby ee_planet » Fri Aug 11, 2017 1:59 am

We just moved to Clarisse 3.5 and have noticed a scene that used to work in Clarisse 3.0.sp7 hangs during rendering.
The render runs up until it reaches 99% completion and then it hangs forever. Here's what it looks like in the log:

Code: Select all
00:00:04      149/150MB  Progress for 'project://scene/image' : 73%
00:00:04      150/150MB  Progress for 'project://scene/image' : 82%
00:00:04      150/150MB  Progress for 'project://scene/image' : 99%


I've included a simplified Clarisse project file that demonstrates the issue.

Here's the command we gave to cnode:
Code: Select all
cnode ./dpt000.v084_simple.clarisse35.project -threads 8 -stats -frames_list 1600:1600%1 -image scene/image -format exr16 -log_width 180


I've noticed the this issue happens regardless of if I used cnode or crender.

We're using Clarisse 3.5 Build 21372 on CentOS 6.3
Are you able to see this issue on your side? Thank you!
ee_planet
 
Posts: 6
Joined: Wed Apr 22, 2015 8:24 pm

Re: cnode render hangs at 99% completion

Unread postby ee_planet » Fri Aug 11, 2017 2:05 am

It looks like I can't submit my example project archive since it's 10MB and the forum has a 1MB limit.
Is there another way to send this project file to you?

Just some notes describing our scene:
The project contains an alembic file for geometry and some materials. We do use a transmission material and the fisheye camera.
ee_planet
 
Posts: 6
Joined: Wed Apr 22, 2015 8:24 pm

Re: cnode render hangs at 99% completion

Unread postby ee_planet » Fri Aug 11, 2017 2:17 am

I've uploaded the debug project file to our Hightail account:
https://spaces.hightail.com/space/sUuIXxDhO2

Please let me know if you have any problems with the link.
ee_planet
 
Posts: 6
Joined: Wed Apr 22, 2015 8:24 pm

Re: cnode render hangs at 99% completion

Unread postby fjutel » Fri Aug 11, 2017 10:39 am

Hi,

Thanks for the project.
This issue is already fixed (ID 7266) and will be released in the next version.

Regards,
Florent Jutel
Isotropix
Clarisse QA
User avatar
fjutel
 
Posts: 266
Joined: Tue Jan 13, 2015 1:21 pm

Re: cnode render hangs at 99% completion

Unread postby ee_planet » Fri Aug 11, 2017 12:11 pm

Thank you. Do you know when the next version will be released?
Also is there a way to check the details of bug ID 7266?
ee_planet
 
Posts: 6
Joined: Wed Apr 22, 2015 8:24 pm

Re: cnode render hangs at 99% completion

Unread postby fjutel » Fri Aug 11, 2017 2:30 pm

We have planned to release the sp1 as soon as possible.
The id is only used to verify, in the release note, that the bug has been fixed.

Regards,
Florent Jutel
Isotropix
Clarisse QA
User avatar
fjutel
 
Posts: 266
Joined: Tue Jan 13, 2015 1:21 pm


Return to Bugs Archive