Isotropix Forums

Anyone experiencing the script editor deleting text?

Clarisse Scripting related topics

Anyone experiencing the script editor deleting text?

Unread postby bvz2000 » Thu Sep 12, 2019 6:51 am

Is anyone else experiencing the issue where, when editing a script in the script editor, selecting text deletes that text? The only solution is to quit and restart Clarisse. This happens to me at work on my CentOS machine as well as at home on my Manjaro machine. This has been happening since Clarisse 2.0, but I can't reproduce it on demand so it is hard to submit as a bug.

Just curious.
bvz2000
 
Posts: 410
Joined: Thu Nov 13, 2014 6:05 pm

Re: Anyone experiencing the script editor deleting text?

Unread postby dboude » Thu Sep 12, 2019 8:53 am

Never seen that :(
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1140
Joined: Mon Jul 03, 2017 10:51 am

Re: Anyone experiencing the script editor deleting text?

Unread postby dane » Thu Sep 12, 2019 3:36 pm

Yes! Have this all the time, also on Centos 7.6.

I havent submitted a bug as I dont know whats causing it, seems random. I found closing the window and making a fresh one does the trick to stop it but it randomly shows up. I'm always backing up my script outside of clarisse because of it.

I have a habit of ctrl + a 'ing all my script to run it and then it just disappears
dane
 
Posts: 85
Joined: Wed Aug 29, 2018 11:50 am

Re: Anyone experiencing the script editor deleting text?

Unread postby anemoff » Thu Sep 12, 2019 3:58 pm

If you ever find consistent reproduction steps please fill in a bug report.

We fixed a bug in 4.0 SP2 that caused display glitches when selectin portions of text. But there might be others still out there.
It looked like this:
clarisse_4.0_sp1_text_editor_glitch.gif
clarisse_4.0_sp1_text_editor_glitch.gif (91.76 KiB) Viewed 298 times


Thanks!
Anthony Nemoff
Isotropix
R&D Engineer
User avatar
anemoff
 
Posts: 191
Joined: Wed Jan 13, 2016 10:10 am

Re: Anyone experiencing the script editor deleting text?

Unread postby bvz » Thu Sep 12, 2019 5:18 pm

The next time it happens (it was fairly regular yesterday) I'll screen grab it. I have not found any consistent reproducability except to just use the script editor under Linux for a while.

Most of the time I use an external editor and just call it from the script editor which limits my exposure. I also notice that closing the script window and creating a new one can fix it for a short while.

Glad I'm not alone in this.
bvz
 
Posts: 51
Joined: Tue Dec 03, 2013 9:55 am

Re: Anyone experiencing the script editor deleting text?

Unread postby dane » Tue Sep 24, 2019 3:22 pm

Been doing quite a bit of scripting in Clarisse the last few days and I've noticed that this bug seems to appear (on Linux) when you ALT+TAB to switch between software in the OS.

I'm usually testing things in clarrise, CTRL+A to select all my script, ALT+TAB to switch to my text editor and pasting it in there. When I ALT+TAB to go back to Clarisse most of the time this causes the issue to arise.

Hopefully you can repeat the problem with that information.

Best,

Dan
dane
 
Posts: 85
Joined: Wed Aug 29, 2018 11:50 am

Re: Anyone experiencing the script editor deleting text?

Unread postby anemoff » Tue Sep 24, 2019 3:33 pm

Thanks for sharing.
We'll try to reproduce it using those steps.
Anthony Nemoff
Isotropix
R&D Engineer
User avatar
anemoff
 
Posts: 191
Joined: Wed Jan 13, 2016 10:10 am


Return to Scripting