Isotropix Forums

Huge exr files

General Discussion about Isotropix and CG related topics

Huge exr files

Unread postby pulverfass » Fri Nov 02, 2018 9:24 am

Hey there,
i dont know how it happend, never had a problem with this in clarisse before:

When rendering/saving an exr file as an 16-Bit exr, with multiple passes, the files get 1gb or more big for one FullHD image. When saving in seperate exr(one for each AOV) files, each one is 300mb, no matter what compression method i use. I can open them in nuke, but nuke almost crashes and takes forever to load. Copied the files to an ssd, didn't really help.
I tried saving each channel as png, had other problems, for example the depth pass didn't work in nuke. What am I doing wrong?

Neither zip nor dwaa or zips compression helped lowering the file size. I checked other renderings in nuke from other DCCs with multiple AOVs, similar resolution, same amount of AOVs etc. Way smaller file size, load quickly in nuke.

I hope you understand my problem,

Cheers,
Robin
pulverfass
 
Posts: 29
Joined: Mon Mar 05, 2018 1:10 pm

Re: Huge exr files

Unread postby dboude » Fri Nov 02, 2018 10:07 am

Hi,

Do you have cryptomatte AOVs in your scene ?

Cheers.
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1206
Joined: Mon Jul 03, 2017 10:51 am

Re: Huge exr files

Unread postby vandam » Fri Nov 02, 2018 10:29 am

I used to have the same problem, I think it was related to the cryptomatte. What version of clarisse are you running?
vandam
 
Posts: 148
Joined: Wed Jun 21, 2017 9:22 pm

Re: Huge exr files

Unread postby pulverfass » Fri Nov 02, 2018 10:33 am

Thanks for the quick replys,
yes i do have cryptomattes, but i used them before, files never went this big.
Clarisse 3.6 SP4
pulverfass
 
Posts: 29
Joined: Mon Mar 05, 2018 1:10 pm

Re: Huge exr files

Unread postby dboude » Fri Nov 02, 2018 10:47 am

Each scattered object is unique. When you use cryptomatte Object AOV, Clarisse writes the path to every single object as metadata in the .exr. So if you have heavy scatterer in your project you have heavy metadata. You should uncheck "Enable Object" in the cryptomatte attributes when dealing with heavy scatterer. We'll add an option to remove/configure those metadata.

Cheers ;)
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1206
Joined: Mon Jul 03, 2017 10:51 am

Re: Huge exr files

Unread postby pulverfass » Fri Nov 02, 2018 11:06 am

Thanks Démian!
Learned something new there.
I have multiple heavy scatterer :D
pulverfass
 
Posts: 29
Joined: Mon Mar 05, 2018 1:10 pm


Return to General Discussion