Page 1 of 1

GlView: Failed to compile GL shader 'plate fragment': 0(15)

Unread postPosted: Thu Jun 13, 2019 9:09 pm
by nisachar
Hello

"GlView: Failed to compile GL shader 'plate fragment': 0(15) : error C1503: undefined variable "OCIODisplay""
I have been getting this error since updating to v4.0 sp2.

Now it seems my second GPU might be an issue, but that was not the case before sp2. Everything worked fine.

I get this of viewport clipping ( even in the render view ) when I am trying to use a displacement

see attached screen shot.

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Fri Jun 14, 2019 8:19 am
by dboude
Hi,

I guess the clipping is not related to the error. Did you set the bound attribute of the displacement? Seems to be set to 0 in all axis. Select the displacement node and raise the bound attribute.

When you have such errors or bugs could you use the bug tracker located here : https://www.isotropix.com/user/bugtracker

Thank you

Cheers ;)

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Fri Jun 14, 2019 8:53 am
by sam
Regarding 4.0 SP2 it's because it enables GPU acceleration in the 3D View.
There are issues with multiple GPU. Follow this thread for the resolution: viewtopic.php?f=5&t=5633&p=20789

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Sat Jun 29, 2019 6:12 pm
by nisachar
@dboude : yes. The bounds was the issue reg the displacement in the render.
@sam : I followed the last suggestion in the forum topic (essentially disabling the other GPUs for Clarisse via Nvidia control panel). I still get the same error Message.
I would prefer if Clarisse had an option in the preferences to disable extra cards. I don’t want to have to enable/disable cards in the system setting ( I use other apps simultaneously at times with Clarisse )
Hopefully there is a fix in a future Clarisse update.

Thanks

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Mon Jul 01, 2019 8:37 am
by dboude
Hi,

You can disable CG cards per software. Please have a look at this thread.

https://forum.isotropix.com/viewtopic.php?f=5&t=5554

Thanks.

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Thu Aug 01, 2019 8:21 am
by nisachar
Not sure what settings I used, but I did disable SLI and chose a single GPU for Clarisse in the nvidia control panel and nowI can use the GPU in the viewport without affecting multi GPU settings for other apps.

Re: GlView: Failed to compile GL shader 'plate fragment': 0(

Unread postPosted: Thu Aug 01, 2019 9:37 am
by dboude
Ok, thanks for sharing.