Page 1 of 1

Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Wed Sep 11, 2019 3:33 am
by aios
...

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Wed Sep 11, 2019 8:22 am
by dboude
Hi,

Your export is not fancy. The value range of your displacement map is very low (0.49 - 0.51). You should have a look at the export settings.

In the meanwhile, you can copy-paste this code into Clarisse. (it will add two nodes). Plug the disp' map in the reorder and the rescale to the displacement node.

Code: Select all
#Isotropix_Clarisse_Clipboard_Serialization 0.94
TextureReorder {
    name "reorder"
    #version 0.9
    copy_from "project://scene/reorder"
    positions "mat_1" 390 501
    input 1 1 1 1
    channel_order "rrr1"
}
TextureRescale {
    name "rescale"
    #version 0.9
    copy_from "project://scene/rescale"
    positions "mat_1" 617 500
    input {
        value 1 1 1
        texture "project://scene/reorder"
    }
    input_min 0.49 0.49 0.49
    input_max 0.51 0.51 0.51
    clamp no
}


That will work but you'll lose a lot of precision.

Cheers ;)

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Thu Sep 12, 2019 5:06 am
by aios
...

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Thu Sep 12, 2019 8:52 am
by dboude
Hi,

Here is the full setup. Just drop the textures in the same folder as the project.

Disp.project
(8.55 KiB) Downloaded 20 times


For ZBrush setting, I guess you should tweak the scale of the displacement attribute. (Old memories)

Cheers

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Fri Sep 13, 2019 1:36 pm
by gdoublet
Hi,

For the Zbrush export make sure to "get scale" before, also have smooth normal activated and once in Clarisse check Prcocess>Use Raw Data and Evaluation>Single Channel File Behavior>Force Luminance in your map file attributes.
Let me know if you get what you want.

Regards

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Sat Sep 14, 2019 2:58 am
by aios
...

Re: Displacement from Zbrush into Clarisse- Not Working

Unread postPosted: Mon Sep 16, 2019 8:27 am
by dboude