Page 1 of 1

Shading

Unread postPosted: Thu Jan 09, 2020 4:14 am
by rajuvfx
Hi
i Am new to clarisse. i have been creating a scene and i have used Standard shader but this shader result gives me kind of edge rim effect.
then i try Disney shader it look correct. can any one tells me where the problem in Standard shader .

Note: Disney shader and aiStandard shader looks same

i have attached the image below

1.Standard shader & Disney shader
2.Arnold Standard Surface
3.Graph

Re: Shading

Unread postPosted: Thu Jan 09, 2020 9:23 am
by dboude
Hi,

That was fixed since Clarisse iFX 4.0 SP5. If you open an older project make sure that the Fresnel Energy Conservation attribute of the standard Matetrial is checked.

Welcome to the community !

Cheers ;)

Re: Shading

Unread postPosted: Mon Jan 13, 2020 12:04 pm
by rajuvfx
Hi.
Thanks. i am using SP3. and i have set it to IOR 1.0

Re: Shading

Unread postPosted: Fri Jan 24, 2020 5:01 am
by oddvisionary
Hi,

You did not fix the issue. By changing the IOR to 1.0 you simply "turned off" the reflection of your material. Technically, you still have reflection but this value results in "cancelling" the F0 fresnel reflection. Your shading will look incorrect.

The only way to fix the issue is to update to Clarisse 4.0 SP5 as Démian mentioned.

Re: Shading

Unread postPosted: Thu Feb 20, 2020 8:00 am
by vopima2188
oddvisionary wrote:Hi,

You did not fix the issue. By changing the IOR to 1.0 you simply "turned off" the reflection of your material. Technically, you still have reflection but this value results in "cancelling" the F0 fresnel reflection. Your shading will look incorrect.

The only way to fix the issue is to update to Clarisse 4.0 SP5 as Démian mentioned.


Yes, buddy, even I was thinking the same 4.0 would still be needed.

Regards,
V. Smith