Page 1 of 1

Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 5:29 pm
by jorgetrevilla
Hi all,

I hope this doesn't sound like a rant. I'm working on a scene for a film project, I obviously can't talk about the details, but the scene is not incredibly large (it only has 62K objects) and geometries are relatively simple. I have to place tons of lights and the slow performance of this makes it very hard and painful to do this (isn't Clarisse supposedly capable of handling billions of geo with ease, or I'm missing something?)- is there a way to make the viewport more responsive? Is there a way to activate the bounding box display mode?

I have this currently on 1/4 Resolution refresh mode (FPS driven is pretty much unusable as it pixelates and fades the image in a very disorienting way)

I hope this makes sense and someone has some tips to share, thanks!

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 7:08 pm
by dboude
Hi,

Which shading mode do you use ? I assume you are using the Progressive rendering.

Do you have streamed map files in the scene ? If yes, try to select them all and lower the mipmap quality level, the textures won't take too much I/O anymore. You can also set a shading layer to the 3D view that assigns a diffuse material to every object during the lighting process.

Let me know if it helps.

Cheers

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 7:44 pm
by jorgetrevilla
Hi,

Thanks for the reply, the mode I'm using is Simple Shading Flat, no textures are displayed at all

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 7:52 pm
by dboude
Perhaps displacement textures are streamed and actives. Only the textures used by displacement can be needed in simple shading.

Let me know if that's the case.

CHeers

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 8:01 pm
by sam
If that's not the case, that's not normal. You might want to contact the IT department since that's not normal. Have you tried running the scene on another machine?

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 8:13 pm
by jorgetrevilla
Just checked and no, and I believe there's should be no displacement, this is also happening on a colleague with a similar spec machine - the geos are referenced alembic bundles

Cheers

Re: Viewport incredibly slow (around 2 FPS)

Unread postPosted: Mon Mar 16, 2020 8:21 pm
by sam
Also check the Progress View to see what Clarisse is doing, but it seems there's something wrong going on.