Isotropix Forums

Rendering artifacts - face normals

General Discussion about Isotropix and CG related topics

Rendering artifacts - face normals

Unread postby machieb » Thu Jun 04, 2020 9:21 pm

Hello,

I often experience rendering artifacts with clarisse.
See attachment "Render_artifacts_01.jpg"
In simple shading mode (smooth) in clarisse the objects looks ok.
See attachment "Render_artifacts_02.jpg"

If I import the same alembic in my dcc app and render the object it looks ok. No artifacts!
See attachment "Render_artifacts_03.jpg"
So it´s not an export or import problem with alembic.

It must have something to do, how the normals are calculated in clarisse?
I played a bit with the smoothing angle but no luck so far the artifacts persist.

Has someone a clue what to do? Is it a clarisse bug?

It is very annoying!

Cheers
Attachments
Render_artifacts_03.jpg
Same Alembic imported and rendered in Blender 2.83. No artifacts.
Render_artifacts_02.jpg
Clarisse simple shading (smooth) mode. No visible artifacts.
Render_artifacts_01.jpg
Clarisse rendering with visible artifacts.
machieb
 
Posts: 38
Joined: Fri Nov 29, 2019 11:20 am

Re: Rendering artifacts - face normals

Unread postby machieb » Thu Jun 04, 2020 9:41 pm

So I tested more and I changed from a disney principled shader to a standard shader.
With the standard shader the artifacts are not visible. So I deleted my shaders and created new shaders and now the artifacts are gone.
Maybe there was something wrong with the shaders. They were created with Clarisse 4.0 SP2 or so, maybe that was the problem?

So hunted down the problem by myself!

Cheers
machieb
 
Posts: 38
Joined: Fri Nov 29, 2019 11:20 am

Re: Rendering artifacts - face normals

Unread postby dboude » Thu Jun 04, 2020 9:51 pm

Cool, I would have say that some polys were missing but nevermind !
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1603
Joined: Mon Jul 03, 2017 10:51 am


Return to General Discussion
cron