Isotropix Forums

Bug projecting from camera?

General Discussion about Isotropix and CG related topics

Bug projecting from camera?

Unread postby bvz2000 » Thu Jun 11, 2020 8:23 am

Code: Select all
#Isotropix_Clarisse_Clipboard_Serialization 0.94
GeometryPolygrid {
    name "polygrid"
    #version 0.9
    copy_from "project://polygrid"
    translate -96.5882223766961 5.6843418860808e-14 -35.0486467940786
    uv_maps "parametric"
    uv_maps_loaded yes
    shading_groups "grid"
    materials "project://default/material"
    clip_maps "project://checker"
    displacements ""
    sg_shading_variables ""
    visibles yes
    deformers ".displacement"
    size 100 100
    spans 200 200
    embedded_objects {
        DeformerDisplacement {
            name "displacement"
            #version 0.9
            copy_from "project://polygrid.displacement"
            scale 100
            texture "project://checker"
        }
    }
}
CameraOrthographic {
    name "orthographic"
    #version 0.9
    copy_from "project://orthographic"
    translate -96.5882223766961 52.6620053761232 -35.0486467940786
    rotate -90.0000000000227 0.0 0.0
    shear 0.0 0.0 0.0
    scale 1 1 1
    rotation_order 4097
    parent ""
    scale_pivot 0.0 0.0 0.0
    rotate_pivot 0.0 0.0 0.0
    scale_pivot_offset 0.0 0.0 0.0
    rotate_pivot_offset 0.0 0.0 0.0
    translate_offset 0.0 0.0 0.0
    rotate_offset 0.0 0.0 0.0
    scale_offset 1 1 1
    rotation_offset_order 4097
    size 100
}
TextureChecker {
    name "checker"
    #version 0.91
    copy_from "project://checker"
    projection 4
    object_space 2
    camera "project://orthographic"
}


I have a project where I am trying to project a clip map from the same camera I am using to project a displacement deformation. The above sample shows the basic concept.

Even if I project the EXACT same image that I am using for the displacement, it does not line up.

Is this a bug? Or am I misunderstanding something?

How can I line up the same image for clipping that I am using for displacement deformation?
bvz2000
 
Posts: 427
Joined: Thu Nov 13, 2014 6:05 pm

Re: Bug projecting from camera?

Unread postby dboude » Thu Jun 11, 2020 8:53 am

Hi,

Unchecking Local transformation in the displacement solves your issue. Another thing, make sure to set the projection to 2D. Here is the scene with corrections.

Code: Select all
#Isotropix_Clarisse_Clipboard_Serialization 0.94
GeometryPolygrid {
    name "polygrid"
    #version 0.9
    copy_from "project://polygrid"
    translate -96.5882223766961 5.6843418860808e-14 -35.0486467940786
    uv_maps "parametric"
    uv_maps_loaded yes
    shading_groups "grid"
    materials "project://matte"
    clip_maps "project://checker"
    displacements ""
    sg_shading_variables ""
    visibles yes
    deformers ".displacement"
    size 100 100
    spans 200 200
    embedded_objects {
        DeformerDisplacement {
            name "displacement"
            #version 0.9
            copy_from "project://polygrid.displacement"
            local_deformation no
            scale 100
            texture "project://checker"
            displacement_axis 1
        }
    }
}
CameraOrthographic {
    name "orthographic"
    #version 0.9
    copy_from "project://orthographic"
    translate -96.5882223766961 150.58279354052 -35.0486467940786
    rotate -90.0000000000227 0.0 0.0
    shear 0.0 0.0 0.0
    scale 1 1 1
    rotation_order 4097
    parent ""
    scale_pivot 0.0 0.0 0.0
    rotate_pivot 0.0 0.0 0.0
    scale_pivot_offset 0.0 0.0 0.0
    rotate_pivot_offset 0.0 0.0 0.0
    translate_offset 0.0 0.0 0.0
    rotate_offset 0.0 0.0 0.0
    scale_offset 1 1 1
    rotation_offset_order 4097
    size 100
}
TextureChecker {
    name "checker"
    #version 0.91
    copy_from "project://checker"
    projection 4
    space 1
    object_space 2
    camera "project://orthographic"
}
MaterialMatte {
    name "matte"
    #version 0.91
    copy_from "project://matte"
    color {
        value 0.0 0.0 0.0
        texture "project://checker"
    }
}


Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1603
Joined: Mon Jul 03, 2017 10:51 am

Re: Bug projecting from camera?

Unread postby bvz2000 » Fri Jun 12, 2020 5:01 am

Thank you so much.

In my real scene I had already done both of those things so I was confused as to why it still didn't work.

As it happens, the data window of the .exr file was bigger than the display window. So apparently the projection for the displacement deformer respects the display window, but the clip map respects the data window. Once I cropped the image so that both were the same, everything worked. Thanks!
bvz2000
 
Posts: 427
Joined: Thu Nov 13, 2014 6:05 pm

Re: Bug projecting from camera?

Unread postby dboude » Fri Jun 12, 2020 8:38 am

Mmmm interesting. Data window, display window... have to dig this ;)

Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1603
Joined: Mon Jul 03, 2017 10:51 am


Return to General Discussion
cron