Isotropix Forums

issue with Normal map

General Discussion about Isotropix and CG related topics

issue with Normal map

Unread postby Karen_Jonhson » Thu Jul 09, 2020 6:19 pm

Megascans normal maps are tangent-space:
https://help.quixel.com/hc/en-us/articl ... -use-them-

Take a polygrid, apply a concrete material: https://quixel.com/megascans/home?categ ... d=sdvjeioa

Add an environment light

Rotate the polygrid as if it's a ceiling, point the camera towards the ceiling/polygrid

I get this (attached), white stuff everywhere including 100% of the edges, the issue is clearly caused by the normal map:

I really do not know how many weeks it takes to reproduce a dead normal grid with a dead normal megascans surface without having issues?

P.S. only 4 maps, exrs
Albedo: Utility - linear - sRGB
AO: use Raw Data, force luminance
Roughness: Utility - linear - sRGB, force liminance
Normal: Utility - linear - sRGB
Attachments
normal map3.JPG
normal map2.JPG
normal map.JPG
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: issue with Normal map

Unread postby ayanik » Thu Jul 09, 2020 6:55 pm

Normal maps should always be set to Raw. Either check the Use Raw checkbox or use the raw aces color space.
ayanik
 
Posts: 89
Joined: Wed Nov 26, 2014 9:10 pm

Re: issue with Normal map

Unread postby Karen_Jonhson » Thu Jul 09, 2020 7:54 pm

Here it is, normal map using raw. That's not the issue.
Attachments
normal map 4.JPG
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: issue with Normal map

Unread postby dboude » Thu Jul 09, 2020 9:11 pm

With and without color ao and roughness. Clearly not a bug. Maps are from RD textures. Everything is by default except Use Raw Data and Force Luminance. Normally it takes 2 min to setup for common users...

Normal_Texturing.png
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1540
Joined: Mon Jul 03, 2017 10:51 am

Re: issue with Normal map

Unread postby mdkai » Thu Jul 09, 2020 9:18 pm

Hi Karen
As it was noted in the sp8 release, a bug was fixed regarding error pixels caused by normal map influenced surfaces.
Let us know if sp8 solves your issue.

Cheers
Kai
Join us at the Discord https://discord.gg/G5cJj9A
mdkai
 
Posts: 340
Joined: Tue Oct 07, 2014 7:24 pm

Re: issue with Normal map

Unread postby ayanik » Thu Jul 09, 2020 9:53 pm

Yeah some fireflies issue was fixed in SP8.

I just tested the 8K Concrete Slab surface using jpg's for all except the displacement, because I'm short on disk space.
I used my Sky Rig plugin and tested several sun elevation angles.

You do see some highlights on the edges of the panels, but that's because the normals of the slab edges are facing the HDRI. Bump and normal maps don't cast shadows so it's normal behavior.

I must also say the HDRI Haven hdri's aren't the best out there.
Attachments
concrete_panels_sky.png
ayanik
 
Posts: 89
Joined: Wed Nov 26, 2014 9:10 pm

Re: issue with Normal map

Unread postby Karen_Jonhson » Sat Jul 11, 2020 3:32 pm

Mdkai. Here is Sp8 render. What do you think?
dboude, It's easy to blame a user of being a novice. I'd let the render speak instead.
Ayanik, get a bit closer to your polygrid, this way you get to see what doesn't belong in the render. Is it normal to have "sugar" spread in the corners of a ceiling?

It's a dead normal and empty scene, one polygrid, one megascans, only 4 texture maps, and it goes terribly wrong. How can we blame a user when it works perfectly in other renderers using the exact same ingredients, have you scene the Houdini mantra render?
Attachments
quick mantra.JPG
sp8.JPG
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: issue with Normal map

Unread postby Karen_Jonhson » Sat Jul 11, 2020 3:38 pm

to be fair here is the sp8 render finished. aa sampling 128, material sampling 256.
Sugar, powder, fireflies ... whatever you want to call it doesn't belong there.
Attachments
sp8 finished.JPG
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: issue with Normal map

Unread postby ayanik » Sat Jul 11, 2020 4:25 pm

Hi Karen. I don't get any fireflies except on very low settings and extreme dark conditions.

I set the following image to 32 aa sample count and 512 refinement sample count.
Attachments
concrete_backlit_hdri.jpg
ayanik
 
Posts: 89
Joined: Wed Nov 26, 2014 9:10 pm

Re: issue with Normal map

Unread postby Karen_Jonhson » Sat Jul 11, 2020 4:30 pm

ayanik wrote:Hi Karen. I don't get any fireflies except on very low settings and extreme dark conditions.

I set the following image to 32 aa sample count and 512 refinement sample count.


We're starting to see something interesting. Good. What have you changed? can I see the material editor? Or even better, the project file as I have the same assets. Thank you
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Next

Return to General Discussion
cron