Isotropix Forums

Black body not working

General Discussion about Isotropix and CG related topics

Black body not working

Unread postby Karen_Jonhson » Sat Jul 11, 2020 3:56 pm

I can't get the black body to work for a Houdini vdb that has Density, Temperature and Velocity.
The vdb and material set up is exactly as in https://www.isotropix.com/learn/tutoria ... sse-part-2

1 vdb
1 volume material (default)
1 black body (default)
1 extract property reading temperature (tried everything actually even with density)

Do you have an idea of what could be the issue? Thank you

P.S. using sp8
Attachments
blackbody1.JPG
blackbody2.png
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: Black body not working

Unread postby dboude » Mon Jul 13, 2020 8:48 am

Hi,

Could you show the values of the temperature in Houdini. Values seem to be normalized and/or rescaled. If that is the case you should drive the "temperature scale" attribute and adjust visually the temperature in the black body node.

Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1603
Joined: Mon Jul 03, 2017 10:51 am

Re: Black body not working

Unread postby Karen_Jonhson » Tue Jul 14, 2020 10:28 pm

temperature in Houdini
Attachments
temperature.JPG
temperature.JPG (18.28 KiB) Viewed 552 times
Karen_Jonhson
 
Posts: 27
Joined: Fri Apr 03, 2020 12:24 pm

Re: Black body not working

Unread postby dboude » Thu Jul 16, 2020 8:23 am

That's not the values that are stored in the VDB. Anyway, try to drive the temperature scale with the extracted property and then adjust the temperature to get the emission.

Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1603
Joined: Mon Jul 03, 2017 10:51 am


Return to General Discussion