Isotropix Forums

Questions about Camera Mapping on YouTube

General Discussion about Isotropix and CG related topics

Questions about Camera Mapping on YouTube

Unread postby flansrjf » Tue Feb 16, 2021 6:37 am

https://www.youtube.com/watch?v=qVyBqHB16A0
Why is the Camera Mapping I did different from the official tutorial?
After I followed the official tutorial, there is still a sideline. Why doesn't it appear in the video tutorial?
Attachments
03.PNG
01.PNG
flansrjf
 
Posts: 45
Joined: Sat Dec 22, 2018 1:56 am

Re: Questions about Camera Mapping on YouTube

Unread postby aaute » Tue Feb 16, 2021 9:40 am

Hi,

I think you miss a part after you enable the "camera occlusion". If you stop the tutorial here and move the view camera (probably what happen in your example) you are going to see the occluded area projected behind the first object with the projection.

You need to apply the diffuse blend technic for the affected objects to avoid this dark line.

Cheers
Aymeric
Isotropix
Technical Artist - Clarisse Specialist
User avatar
aaute
 
Posts: 45
Joined: Mon Nov 02, 2020 11:59 am

Re: Questions about Camera Mapping on YouTube

Unread postby flansrjf » Tue Feb 16, 2021 2:52 pm

Thanks for reply
I understand this principle. But in the end there will still be very thin lines.
I think the reason for this is that anti-aliasing is handled when rendering the edges of objects. Will it not be so accurate after subtracting the geometry?
Attachments
04.PNG
flansrjf
 
Posts: 45
Joined: Sat Dec 22, 2018 1:56 am

Re: Questions about Camera Mapping on YouTube

Unread postby aaute » Tue Feb 16, 2021 5:30 pm

Hi,

yes you are right, to avoid this you need to save your image at least at double resolution and be sure to set the filtering of your image at box 1x1.

Cheers
Aymeric
Isotropix
Technical Artist - Clarisse Specialist
User avatar
aaute
 
Posts: 45
Joined: Mon Nov 02, 2020 11:59 am

Re: Questions about Camera Mapping on YouTube

Unread postby RayCaster » Wed Feb 17, 2021 2:26 am

what if you had an empty black layer as a base layer.
RayCaster
 
Posts: 51
Joined: Fri Oct 11, 2019 5:02 pm

Re: Questions about Camera Mapping on YouTube

Unread postby flansrjf » Wed Feb 17, 2021 8:47 am

In fact, I have tried the method you mentioned. Even I tried to output 400% size, box 1x1, but still can't solve it. The only way I can think of at the moment is to export the camera OCCLUSION as a black and white image and manually expand the black border in Photoshop. It's just that it is troublesome to do so.
flansrjf
 
Posts: 45
Joined: Sat Dec 22, 2018 1:56 am

Re: Questions about Camera Mapping on YouTube

Unread postby flansrjf » Wed Feb 17, 2021 1:09 pm

RayCaster wrote:what if you had an empty black layer as a base layer.

I'm very sorry, I don't quite understand what you mean. What is this idea?
flansrjf
 
Posts: 45
Joined: Sat Dec 22, 2018 1:56 am

Re: Questions about Camera Mapping on YouTube

Unread postby RayCaster » Wed Feb 17, 2021 6:37 pm

I've not tried camera mapping( have seen the example but have trouble figuring out how or why I would need to use it) so not sure it's a solution, are you rendering layered images? or if you open the file in gimp and create a black base layer, does your issue still show.
RayCaster
 
Posts: 51
Joined: Fri Oct 11, 2019 5:02 pm

Re: Questions about Camera Mapping on YouTube

Unread postby NiklasW » Fri Feb 19, 2021 3:20 pm

I have this problem all the time! It has something to do with the antialiasing. Some people have no problems what so ever but I get it every time. Even when I render ID's for Photoshop the issue remains. I had posted this two times in the forum and never got a satisfying answer. I hope they can fix this!
NiklasW
 
Posts: 27
Joined: Mon Aug 03, 2020 9:06 am

Re: Questions about Camera Mapping on YouTube

Unread postby flansrjf » Sun Feb 21, 2021 3:15 pm

NiklasW wrote:I have this problem all the time! It has something to do with the antialiasing. Some people have no problems what so ever but I get it every time. Even when I render ID's for Photoshop the issue remains. I had posted this two times in the forum and never got a satisfying answer. I hope they can fix this!

I also hope to solve this problem, because this is very important to my creation
flansrjf
 
Posts: 45
Joined: Sat Dec 22, 2018 1:56 am

Next

Return to General Discussion