Page 1 of 1

Texture map differences local (windows)/ farm (linux)

Unread postPosted: Tue Oct 12, 2021 5:14 pm
by Watchyato
Hi All,

We seem to have run into a slight issue with our normal maps when rendering locally (windows) and rendering on our farm(linux), I've included a test scene which includes test renders of both scenarios.

The issue seems to be that the normal map renders very sharp on the linux machines but soft on the windows machines (see images below)

We are using clarisse 5, local renders using interactive clarisse and the farm uses cnode. I would note that when the farm renders on a windows machine, it renders the same as a local render.

Re: Texture map differences local (windows)/ farm (linux)

Unread postPosted: Tue Oct 12, 2021 5:39 pm
by Watchyato
On further inspection it may be the displacement map that causes the issue, here are my image below normals disabled and only displacement on

Re: Texture map differences local (windows)/ farm (linux)

Unread postPosted: Tue Oct 12, 2021 5:51 pm
by Watchyato
Looks like the issue is coming from using adaptive displacement, the issue is resolved when switching to uniform

Re: Texture map differences local (windows)/ farm (linux)

Unread postPosted: Wed Oct 13, 2021 10:10 am
by Lucas
Hey Watchyato,

It's nice if you found a workaround, but I couldn't replicate the issue. Could I have your simple scene ans the maps associated ?

Thanks,

Re: Texture map differences local (windows)/ farm (linux)

Unread postPosted: Wed Oct 13, 2021 4:19 pm
by Watchyato
My apologies i thought i had added it, here it is.

I would also note we have sorted the issue out by upgrading to Clarisse 5.0-sp4, still very strange behaviour none the less.