Isotropix Forums

USDskel issues

General Discussion about Isotropix and CG related topics

USDskel issues

Unread postby sysadminGhost » Thu Dec 01, 2022 2:15 pm

I am testing to see if clarisse can read in our USDskel based outputs for a project we are doing. But clarisse just returns this error:

[usd] [diagnostics] Failed verification: ' IsValid() ' -- invalid anim query.

the same cache is working fine in
houdini
vray
USDviewer

Has anybody else had issues with USDskel based deformations?

I can't share the specific cache, (that would be the best), but reading in the pixar USDskel example file called humanFemale.usd triggers the same error. (I don't know if it is the same issue). You can download the file here:
https://graphics.pixar.com/usd/release/ ... mples.html

I'm on SP8 on linux.

Cheers

/Martin
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby dcourtois » Thu Dec 01, 2022 3:39 pm

Hi,
That's weird, the Pixar example you mention is the one we're using in our internal tests. I've just tested it again (on Windows though) and it seems to work fine. Could you try to load that example on SP9b and tell me if it also fails?
Also, do you have the error on *all* USD stages, or just on ones containing skels?
User avatar
dcourtois
 
Posts: 123
Joined: Tue Jul 25, 2017 3:15 pm

Re: USDskel issues

Unread postby sysadminGhost » Thu Dec 01, 2022 6:02 pm

Thank you for the quick reply. I currently only have access to sp8 on linux. I can request sp9, but it will probably take some time before IT would be able to provide it.
Normal USD's works just fine. Only USDskel files have given me these errors.
One thing to note is that it is only one of the three usd files in the pixar example I get an error on. (the one mentioned above.)

I can see if I can do some more testing on my windows box at home and see if I get the same result you do.
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby sysadminGhost » Fri Dec 02, 2022 9:49 am

Tested the same pixar file on windows in sp8 and I get the same error. Will try sp9 next.
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby sysadminGhost » Fri Dec 02, 2022 11:52 am

Tested on sp9 and got even more error messages. Sp8 gave me 1, sp9 it outputs rows and rows of the same error.
Am I doing something wrong? Do I need to do anything different than loading a normal USD?
Or does it have any python dependency's? Not sure why I'm seeing these errors and you don't.
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby dcourtois » Fri Dec 02, 2022 4:18 pm

Hi again,
Since then I've also tested on Linux, and still no issue (also all our automatic testing machines are running that same test, and no issues there)
I have no clue what's happening, but this error kinda rings a bell... I think I had that one once when I was testing new version of the USD libraries, and it was a mistake on my part which resulting the USD module of Clarisse using version X of USD, and the actual USD library version that was loaded was Y. So there was a conflict, and the error was something cryptic like the one you mentioned.

So based on that, maybe there's a conflict between Clarisse and your other DCCs (some will update the system's environment variables, which "could" result in Clarisse picking the incorrect USD library) So what I would do would be to install Clarisse on a computer with nothing else on it (and with the environment variables cleaned up) and see if you still get the error. My guess is that you won't. And from there re-install the other softwares and try loading the skel in Clarisse. If my guess is correct at some point you'll find which one causes the issue (chances are that it'll have to do with some environment variables)

And if you still get the error on a clean computer, then I'm not sure... maybe it's a hardware issue? But this is a bit out of my expertise, so I'm not sure how I would diagnose that :/
User avatar
dcourtois
 
Posts: 123
Joined: Tue Jul 25, 2017 3:15 pm

Re: USDskel issues

Unread postby dcourtois » Fri Dec 02, 2022 4:40 pm

Quick update!
I always tested this by only referencing `humanFemale.walk.usd`. But someone here tried to select both that file and the other .usd ones in the folder, and *now* we have the error!
So there's definitely something fishy with multiple files and USD skels in our USD references. Would you mind opening a bug in the bug tracker explaining the issue? As for the repro, just put the following: "Download the UsdSkel examples from Pixar, and reference both HumanFemale.usd and HumanFemale.walk.usd at the same time". I'll take it from there :) (and you'll be notified when it's fixed)
User avatar
dcourtois
 
Posts: 123
Joined: Tue Jul 25, 2017 3:15 pm

Re: USDskel issues

Unread postby sysadminGhost » Fri Dec 02, 2022 4:56 pm

Thank you for looking into this. Sounds like the issue is on my end then. Strange.... I don't have much experience with USDskel. Do you just download the files and then open them? Or do you edit something?
I only have a default installation of clarisse ple here at home. I have not set any env. variables so I do not know what is going on.
What env variables should i look for?
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby sysadminGhost » Fri Dec 02, 2022 4:57 pm

Ah, ok, the plot thickens! I will do so. Thank you!
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Re: USDskel issues

Unread postby sysadminGhost » Fri Dec 02, 2022 5:09 pm

Ok, bug has been submitted now.
sysadminGhost
 
Posts: 21
Joined: Tue Sep 15, 2020 10:13 am

Next

Return to General Discussion