Isotropix Forums

Tree material too bright compared to original dark material

General Discussion about Isotropix and CG related topics

Tree material too bright compared to original dark material

Unread postby lookdev » Tue Sep 03, 2019 11:51 am

The tree material looks too bright compared to the original dark material from SpeedTree. I tought it was the exposure of the ibl, brought it down to -5 and I still see this (attachment).
Am I doing something wrong?
Attachments
tree in speedtree.PNG
tree too bright.PNG
lookdev
 
Posts: 64
Joined: Sun Apr 30, 2017 1:08 pm

Re: Tree material too bright compared to original dark mater

Unread postby dboude » Tue Sep 03, 2019 1:02 pm

Hi,

It's not the same render engine. Lighting is not even the same in the two examples. How can it match?
You have to tweak your material manually...

Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1173
Joined: Mon Jul 03, 2017 10:51 am

Re: Tree material too bright compared to original dark mater

Unread postby jandersunstar » Tue Sep 03, 2019 2:19 pm

When doing look dev is always good to have your AOV on and watch what each component is doing. I bet is the specular that gives you that look.
aov.png

Cheers!
User avatar
jandersunstar
 
Posts: 298
Joined: Fri Jun 06, 2014 8:21 pm
Location: Mexico City

Re: Tree material too bright compared to original dark mater

Unread postby lookdev » Wed Sep 04, 2019 12:15 pm

Even with no lights I get the same problem with a different 3D model, with Clarisse own standard Material (kept default, just changed to Gold).
I can try on a hundred different models without any light, I feel the result will be the same. There is something with the progressive rendering. The previz shows how th materials shoudl look like but the progressive rendering, with lights off, has everything mega overexposed, with no lights, with Clarisse own material:
Attachments
previz.PNG
clarisse.PNG
lookdev
 
Posts: 64
Joined: Sun Apr 30, 2017 1:08 pm

Re: Tree material too bright compared to original dark mater

Unread postby oddvisionary » Wed Sep 04, 2019 12:30 pm

This is why. You have an environment, which is a light source. Turn the intensity to 0 (black) to turn it off, or CTRL + D/H
Attachments
firefox_2019-09-04_13-28-40.png
firefox_2019-09-04_13-28-40.png (1.75 KiB) Viewed 610 times
Clarisse Discord Server: https://discord.gg/he8QTvD

3D & Tech Artist at Quixel | CG Lead & Pipeline TD, Sound Designer & Effect Recordist at ODDVISIONARY studio
oddvisionary
 
Posts: 10
Joined: Fri Feb 01, 2019 8:59 pm

Re: Tree material too bright compared to original dark mater

Unread postby lookdev » Sat Sep 07, 2019 9:48 pm

I wouldn't give up that easily, I've checked it again and look at this:
Light exposure -100, and for fun I disable it
Environment exposure -100, and for fun I also disable it
so it is theoretically dark, but I can still see the tree. Why?
Well, I've checked the usual suspects: there is a material called "shadow cacher" which again just like it's cousin the "matte", happens to EMIT LIGHT.
Now can Isotropix explain why would a shadow catcher emit light? like seriously, we are going to spend days to figure out that the matte emits light (it seems to be a legacy historic issue, code not updated after the new emitter material is added), and we will spend more days to figure out that the shadow cacher is emitting light. Does everything have to emit light? I'd rather spend time learning the parts of Clarisse that make sense.
Look at this, this is beyond logic, or beneath logic (the images are in reverse order of the sequence of events):
Attachments
clarisse3.PNG
clarissebug2.PNG
clarissebug.PNG
Last edited by lookdev on Sat Sep 07, 2019 9:54 pm, edited 2 times in total.
lookdev
 
Posts: 64
Joined: Sun Apr 30, 2017 1:08 pm

Re: Tree material too bright compared to original dark mater

Unread postby lookdev » Sat Sep 07, 2019 9:50 pm

So I have to disable the shadow catcher for the lighting to start behaving as we know it from life. But if I turn on the lights with exposure 0, and the shadow catcher is on, then I get an over exposed image (while all lights have exposure 0, yes both environment and light).
Did I get it wrong or do I keep coming across too many materials that just emit light for no reason?
Is it not better to call a bug a bug and try to fix it?
Attachments
clarissebug4.PNG
lookdev
 
Posts: 64
Joined: Sun Apr 30, 2017 1:08 pm

Re: Tree material too bright compared to original dark mater

Unread postby dboude » Mon Sep 09, 2019 9:13 am

Hi,

You have this 5 min long tutorial covering all the facets of the shadow Catcher. https://youtu.be/_5PqNrrXKJY?t=65
I put a time stamp so you can directly learn why the shadow catcher emits lights. If you don't watch our tutorials, it's normal that you spend days clicking everywhere to match what you have in mind...

In the images you have posted, everything looks fine and logic.

The first one: every light sources are deactivated so your scene is black. BUT the background of your 3D view is still dark blue/grey. What you see is the BACKGROUND of the 3D view :o . Progressive Rendering doesn't remove the background of the 3D View. But if you want it all black go to the option of the 3D view and set a black constant color to the background color.

If you have an overexposed image with an ibl, check your HDRI maybe values are too strong in it.

Here is a snapshot of two objects and two lights. All attributes to default values ---> nothing is overexposed.

Image

Cheers
Démian
Isotropix
Technical Artist - Clarisse Specialist
User avatar
dboude
 
Posts: 1173
Joined: Mon Jul 03, 2017 10:51 am

Re: Tree material too bright compared to original dark mater

Unread postby lookdev » Mon Sep 16, 2019 6:53 pm

dboude wrote:The first one: every light sources are deactivated so your scene is black. BUT the background of your 3D view is still dark blue/grey. What you see is the BACKGROUND of the 3D view :o . Progressive Rendering doesn't remove the background of the 3D View. But if you want it all black go to the option of the 3D view and set a black constant color to the background color.


Thanks. I think you addressed the wrong image. I mentioned the images are in reverse order (that's how the upload does it), so the dark one is fine, I uploaded it for reference only showing when I disable the shadow catcher.
The last image is the first one in the sequence of events. When I say it's supposed to be dark then I meant this one where all the lights are off yet the tree is lovely bright and colourful.
Attachments
clarissebug.PNG
lookdev
 
Posts: 64
Joined: Sun Apr 30, 2017 1:08 pm

Re: Tree material too bright compared to original dark mater

Unread postby bvz » Tue Sep 17, 2019 12:41 am

Did you check out the tutorial on how shadow catchers work? A shadow catcher SHOULD emit light, otherwise your asset will not render properly against whatever plate you are putting it over. In other words, the shadow catcher emits the color of the light that is bouncing from the plate onto the object.

So, if you have a bright green field onto which you are going to composite your tree, then you want the emission color to be the color of this bright green field. One way to do that is to project the plate from the rendering camera and put that into the color for the the shadow catcher. In this way, the shadow catcher will "bounce" the color of the plate onto your object. By default the bounce color is set to pure white. Perhaps you think that the default should be a different color, and maybe that makes sense. Maybe not. But the behavior is exactly correct.

If you do not want this behavior, simply turn the color of the emission of the shadow catcher to 0 0 0 .

Check out the tutorial and it will make sense.
bvz
 
Posts: 51
Joined: Tue Dec 03, 2013 9:55 am

Next

Return to General Discussion