Isotropix Forums

Can't get Python to work on linux

Clarisse Scripting related topics

Re: Can't get Python to work on linux

Unread postby pankaj » Sat Aug 26, 2017 3:01 pm

I would like to inform that by following few steps I am able to run Clarisse 3.5 on Linux Mint 18.2
Initially I got following
error: Failed to find python 2.7 library. Please check that or is available through LD_LIBRARY_PATH paths

which I resolved by
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/

Next I resolved following error
ImportError: No module named site

by changing clarisse.env entries. If you already tried to run Clarisse then as mentioned above change it in ~/.isotropix/clarisse/3.5

Upon this Clarisse attempt to start but end with error like
Traceback (most recent call last):
File "/usr/lib/python2.7/", line 563, in <module>
File "/usr/lib/python2.7/", line 545, in main
known_paths = addusersitepackages(known_paths)
File "/usr/lib/python2.7/", line 272, in addusersitepackages
user_site = getusersitepackages()
File "/usr/lib/python2.7/", line 247, in getusersitepackages
user_base = getuserbase() # this will also set USER_BASE
File "/usr/lib/python2.7/", line 237, in getuserbase
USER_BASE = get_config_var('userbase')
File "/usr/lib/python2.7/", line 582, in get_config_var
return get_config_vars().get(name)
File "/usr/lib/python2.7/", line 528, in get_config_vars
File "/usr/lib/python2.7/", line 412, in _init_posix
from _sysconfigdata import build_time_vars
File "/usr/lib/python2.7/", line 6, in <module>
from _sysconfigdata_nd import *
ImportError: No module named _sysconfigdata_nd

Which got resolved by issuing following command
sudo ln -s /usr/lib/python2.7/plat-*/ /usr/lib/python2.7/

Although these steps already mentioned in the post but I tried all these Linux MInt 18.2 and now sccuessfully runing Clarisse 3.5
Posts: 1
Joined: Fri Aug 25, 2017 6:07 pm

Re: Can't get Python to work on linux

Unread postby bvaldes » Mon Aug 28, 2017 9:10 am


thanks for your feedback, that will help others users.

Clarisse QA
User avatar
Posts: 240
Joined: Mon Sep 26, 2016 11:44 am

Re: Can't get Python to work on linux

Unread postby Asticles » Wed Apr 11, 2018 7:25 pm

WOW this worked for me to run it on ubuntu. Please put it on docs.

Posts: 22
Joined: Sun Feb 23, 2014 4:52 pm

Re: Can't get Python to work on linux

Unread postby revilo3d » Fri Jun 15, 2018 8:43 am

Got me going on Linux Mint 19. Thank you - I would have gone at it for a few more hours without figuring that out!
Posts: 21
Joined: Sat Aug 27, 2016 11:10 am


Return to Scripting